[Bdi4emc-help] Install Help please

Arthur Butler arthurbutler at otters.ndo.co.uk
Fri Dec 30 18:56:02 CET 2005

Hi Paul,

Thank you for your comments, and those of Kent. I retried the install 
without capitals, since I had used them. Same result. I gave up, and 
used a Debian testing install, using the new experimental GUI installer 
for a laugh. I now, I think, have a working EMC box, but haven't yet 
built any of the electronics to run stepper motors with. Having done 
this install, I think I've realised what the problem may be since a 
similar thing happened with that install, but less severe, a few minutes 
with Knoppix and it was bootable. I feel a bit silly now, but would have 
expected the install script to check this if it is what I think. I 
called the normal user account "operator", and Debian already creates 
this user and group, so it fails! I wonder if my foolish error could be 
documented to help anyone else who might have that problem in future?

A few other comments, if I may?

I like the fact that you're using Debian-provided easy updates, and 
supports many architectures.

I'm now using 256MB RAM, I just hadn't tested the second 128MB, so was 
installing without it.

LVM works now. I'm also using xfs-a journeling file system, little bit 
faster than ext3, no efsck time, well-developed, and not subject to as 
many changes as reiser. I'm just tinkering, so I'm happy to try newer 
things-it doesn't have to work flawlessly like a server!

Could you tell me which of your packages modifies /etc/apt/sources.list 
please? I'm using testing and a few other unofficial repositories too, 
so want to look out for it being changed by a new version of a package. 
This happened to me-I'd set up sources.list, then installed your 
packages, and lost it all!

One of your bdi-branding packages (I forget which, but can tell you 
another day if you want) failed to install-it does 5 patches which 
didn't apply cleanly, so I've removed it.

Do you use initrd kernels? When I installed your kernel I didn't get an 
initrd, so have created it myself. Could just be an issue with the 
experimental nature of the GUI installer I used-gave a lilo error during 
the install.

Thanks again,

Happy New Year,


More information about the Bdi4emc-help mailing list