Call for Position Papers on Internet Design Principles
---------- Forwarded message ---------- From: stef <[email protected]> Date: Thu, Apr 28, 2011 at 5:29 AM Subject: [fcf_discussion] FWD: Call for Position Papers on Internet Design Principles To: fcforum_discussion <[email protected]> anyone has any idea what's this about?
EUROPEAN COMMISSION
Information Society and Media Directorate-General
Converged Networks and Services
*Networked Media Systems*
Brussels, 27 April 2011
INFSO/D2 ILB/vdp D(2011)
This is a reminder for the Internet Design Principles Call for contributions with deadline 10 May 2011.
The Call for position papers is also published at the following link:
http://ec.europa.eu/information_society/activities/foi/research/fiarch/index...
Encl: call for position papers.
*Call for Position Papers on Internet Design Principles*
Design principles play a central role in the architecture of the Internet
as
driving most engineering decisions at conception level but also operational level. Often cited as the corner stone of the Internet design compared to architectures that rely exclusively on design model (derived directly from requirements), they are for most of them not formally defined by means of a closed mathematical formulation.
Design principles suggest normative rules on how a designer/an architect can best structure the various architectural components and describe the fundamental and time invariant laws underlying the working of an engineered artifact. Note that the canonical definition of architecture (as specified in
http://ec.europa.eu/information_society/activities/foi/docs/current_internet... )
includes the principles and guidelines governing their design and evolution over time.
For what concerns the Internet (as engineered artifact), its architecture is governed by the following design principles (this list is not exhaustive and represents the common baseline in terms of principles currently applied to the Internet architecture and its operation):
· Modularization by relaxed layering
· Connectionless datagram forwarding
· Network of collaborating networks (Interconnection via gateways)
· End‐to‐end principle/fate sharing principle combined with
· intelligent end systems (user stateless network)
· Simplicity principle
· Loose coupling principle
· Locality principle (local cause(s) shall result in local effects)
The present call for contributions aims to address the issue of design principle applicability by identifying the necessary addition/possible improvement to the current principles. It is to be emphasized that a large part of the underlying research activity consists of identifying hidden relationships and effects between them.
For this purpose, clear understanding about what individual projects actually do and how they position against these design principles is to be better identified. Position statements from various projects and research activities are expected to provide better insight on associated architectural challenges. For this purpose contributions shall be centered
on the following questions:
*Which design principles your project is currently addressing /*
*relying on?*
*Which design principles does your project challenge and for which*
*reasons?*
*Which design objectives can't be achieved by application of current*
*design principles?*
*Do you plan investigation on new principles or modification of*
*existing principles ?*
*Which design principles (or adaptation of existing principles) would*
*be required to address your design objectives ?*
* *
* *
*Please provide your input to the **fiarch@future**‐**internet.eu **by **10 May** 2011.*
* *
* *
*References and Reading Material:*
‐ R.Bush and D. Meyer, Some Internet Architectural Guidelines and
Philosophy, IETF, RFC 3439 (updates RFC 1958), December 2002.
‐ R.Callon, The Twelve Networking Truths, IETF, RFC 1925, April 1996.
‐ B.Carpenter, Ed., Architectural Principles of the Internet, IETF, RFC
1958, June 1996.
‐ B.Carpenter, Internet Transparency, IETF, RFC 2775, February 2000.
‐ B.Carpenter and S.Brim, Middleboxes: Taxonomy and Issues, IETF, RFC 3234,
February 2002.
‐ D.Clark, The design philosophy of the DARPA internet protocols, ACM
SIGCOMM Computer Communication Review, Vol.18, No.4, pp.106‐114, August
1988.
‐ J.Kempf, Ed., R.Austein, Ed., The Rise of the Middle and the Future of
End‐to‐End: Reflections on the Evolution of the Internet Architecture,
IETF, RFC 3724, March 2004.
‐ T.Moors, A critical review of "End‐to‐end arguments in system design,
Proceedings of IEEE International Conference on Communications (ICC)
2002, New York City (New Jersey), USA, April/May 2002.
‐ J.Saltzer, D.Reed, and D.Clark, End‐to‐end arguments in system design,
ACM Transactions on Computer Systems, November 1984.
‐ FIArch document: FIArch Group, “Fundamental Limitations of Current Internet and the path to Future Internet,” December 2010 URL:
http://ec.europa.eu/information_society/activities/foi/docs/current_internet... -- gpg: https://www.ctrlc.hu/~stef/stef.gpg gpg fp: F617 AC77 6E86 5830 08B8 BB96 E7A4 C6CF A84A 7140 ----- +info http://list.fcforum.net/wws/info/fcforum_discussion ---- -- P2P Foundation: http://p2pfoundation.net - http://blog.p2pfoundation.net Connect: http://p2pfoundation.ning.com; Discuss: http://lists.ourproject.org/cgi-bin/mailman/listinfo/p2p-foundation Updates: http://del.icio.us/mbauwens; http://friendfeed.com/mbauwens; http://twitter.com/mbauwens; http://www.facebook.com/mbauwens
participants (1)
-
Michel Bauwens