Evil commit 6841 doesn't work for mark-defun

York Zhao gtdplatform at gmail.com
Tue Aug 9 17:34:08 CEST 2011

Hi Vegard,

I appreciate your work on this and yes the "make emacs" worked for this. And
I then noticed that both `mark-defun' and `c-mark-defun' have been adviced
by senator (in Cedet). I have tested without loading cedet and it worked
fine. I also tested loading cedet without evil and it still doesn't work, so
apparently the problem is caused by cedet not evil. Sorry about that.



On Mon, Aug 8, 2011 at 6:00 PM, Vegard Øye <vegard_oye at hotmail.com> wrote:
On 2011-08-08 16:57 +0200, York Zhao wrote:

> When I start emacs without evil, I press "C-M-h" and the current
> function is selected, pressing "C-M-h" again the following function
> is selected, pressing again will selecte the third one etc. But if
> evil is loaded, even in Emacs State, I can only have the current
> function selected, the selection would not expand when I press
> "C-M-h" again.

Commit fba5e8e removes `mark-defun' et al. from `evil-motions' and
adjusts Evil's region behavior.

If this doesn't fix the problem, then please start a fresh instance
of Emacs by running "make emacs" in Evil's directory and reproduce
the bug there. It would also help if you could provide an excerpt of
the actual code (functions) that you are selecting with "C-M-h".

(It's rather strange that you are seeing the same behavior in
Emacs state. I would appreciate more details, as I am unable to
reproduce this myself.)


implementations-list mailing list
implementations-list at lists.ourproject.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ourproject.org/pipermail/implementations-list/attachments/20110809/4bce6210/attachment.htm 

More information about the implementations-list mailing list