bind <tab> to vimpulse-abbrev-expand-before in insert mode

Titus von der Malsburg malsburg at
Fri Dec 17 11:38:27 CET 2010

Dear list,

I'd like to be able to expand words and symbols by pressing the tab
key in insert mode.  I tried this method:

  (vimpulse-imap [(tab)] 'vimpulse-abbrev-expand-before)

But when I press tab in insert mode after evaluating this nothing
happens.  I'm was running emacs -nw.   The strange thing is that it
does work when I run emacs with the graphical user interface (GNU
Emacs 23.1.1 from Ubuntu lucid).  Any ideas about what is going on
here and how I can fix it?

The other problem I'm having is that C-v does not activate block
selection but inserts text.  I'd be happy about any suggestion!

Here's my init.el, not much going on there:

  (require 'slime)
  (setq inferior-lisp-program "/usr/bin/sbcl")

  (load "~/.emacs.d/vimpulse.el")

  (setq-default fill-column 80)
  (mouse-wheel-mode t)
  (setq auto-fill-mode 1)
  (add-hook 'text-mode-hook 'turn-on-auto-fill)
  (xterm-mouse-mode t)

  ;; tab expands
  (vimpulse-imap [(tab)] 'vimpulse-abbrev-expand-before)
  ;; cycle buffer as in chrome
  (global-set-key (kbd "C-<next>") 'next-buffer)
  (global-set-key (kbd "C-<prior>") 'previous-buffer)

Sorry, for these basic questions.  I just switched to emacs after
having used vim for 10 years.  I'm a bit lost.


More information about the implementations-list mailing list